Home > technology > Mozilla Weave 0.5 server

Mozilla Weave 0.5 server

September 12, 2009

Trying to set up Weave for local bookmark sync. Has used Foxmarks before but it screwed up.

Got an old linux box with Apache2. OpenSSL. Had Webdav running on it before. Vaguely recall trying to set up Weave at version 0.2.x before.

Added a virtualhost for weave. Errors – SSL and multiple virtual hosts don’t work well. Removed the old virtual host from sites-enabled and started to get somewhere.

Then needed a new self signed cert because I had changed the machine name. Not a self signed CA cert but a self signed, private key transporting cert. (see 4.1 in http://www.openldap.org/pub/ksoper/OpenLDAP_TLS.html#4.0)

Then started to get errors when client connecting a la :

Invalid method in request \x16\x03\x01

Changed the

<VirtualHost MyServerName:443>

back to

<VirtualHost *.443>

. Suspect Apache resolving servername to something other than whats in the cert.

Now I can almost connect : error log showing some dirs dont exist. Start adding them. one by one as a I login. Eventually it gets to the point where there are no more errors baout missing dirs, but instead “Couldnt sign in : null”. Very useful indeed.

Now Ive discovered the weave website has a lot more information than it used to have. Theres a download for the server side directory structure. I’ll get that and give it another whirl in the coming days.

Oct 23 : Given up on weave as it requires that webDav is no longer used, and i need it for svn among other things. So using Xmarks as the alternative for now and will see how it goes – got scrambled bookmarks last time i used it (as early version of FoxMarks)

Advertisements
Categories: technology Tags:
%d bloggers like this: